HomeОбразованиеRelated VideosMore From: Focus Photo School

How To Fix The Adobe Photoshop Lightroom Catalog Is Too New Error Message

55 ratings | 24084 views
(FREE TUTORIAL) How To Fix The Adobe Photoshop Lightroom Catalog Is Too New Error Message A number of the photographers that I assist in private one-on-one Adobe Photoshop Lightroom technical support sessions have been reporting a similar error message lately. Each of these clients reports receiving an error message that says that their Adobe Photoshop Lightroom Catalog "cannot be opened because it is too new to be used by this version of Lightroom." Usually this error message appears a few day after installing a Photoshop Lightroom update or upgrading from an older version of the Lightroom application. Fortunately, there is a quick and easy solution to this problem. If you encounter this error message on startup then all that you need to do is to tell your computer to open this Lightroom Catalog (your .lrcat file) using the most recently installed version of the Lightroom Application. In the Mac world, this is best done by right-clicking on your .lrcat file and using the Open With command. Windows users will find the same command with a right-click although so far I have mostly seen this error on computer's running the Mac operating system. ------------ Learn Adobe Photoshop Lightroom, Adobe Lightroom for Mobile, Snapseed from Google, and more with our complete video training courses at http://www.focusphotoschool.com. FocusPhotoSchool.com subscribers receive unlimited access to hundreds of in-depth video tutorials from Adobe Certified Lightroom and Photoshop Expert David Marx. Visit our website today to take your photography to the next level!
Html code for embedding videos on your blog
Text Comments (16)
Lexie J (3 days ago)
So, I did that, but the error is still coming. I haven't deleted the other programs yet, because I don't want to have NO way of opening it, until I'm sure this works. Do I HAVE to delete prior programs for this work, and trust that it will???
Focus Photo School (3 days ago)
The only step here that really matters is specifying which version of Adobe Photoshop Lightroom opens up your .lrcat file. Once you have told your operating system to use the latest version that it is the default application for .lrcat type assets then you have solved the problem. Uninstalling older versions of the Lightroom application just frees up a little disk space and prevent future confusion.
Federico Uribe (5 months ago)
Save ma day ! Thanks Brou ! 👌👍✌
Donnie Teja (5 months ago)
what to do for windows?
Focus Photo School (4 months ago)
I believe that this solution should work for you too. Just select the most recent version that you have installed on your computer.
Alex 033 (4 months ago)
But what if i don't have the latest version?
Focus Photo School (5 months ago)
I have not seen this error on a lot of Windows computers but I believe that the solution is the same. Use a right click then select the Open With command and designate the latest version of Lightroom that is inside your Programs folder.
Jim Trull (5 months ago)
Thanks for this video. It saved may ass. I was starting to freak out when I got the error message. Very helpful video.
Alexander Raven (5 months ago)
is there a way on windows of doing this?
Focus Photo School (5 months ago)
You can do the same thing, I believe, using a right-click and then the Open With command. That said, I have not heard of Windows users encountering this specific problem so please let me know if this solution works for you.
Guadilarious (6 months ago)
THANK YOU
Focus Photo School (6 months ago)
You are welcome. Glad this helped.
Shreyans Shrishrimal (10 months ago)
Thank you so much.
Focus Photo School (10 months ago)
Your welcome. Glad this tutorial helped!
CliqueSydney (1 year ago)
Thank you , this fix saved me a BIG headache :-)
Focus Photo School (1 year ago)
Your most welcome! Glad this helped.

Would you like to comment?

Join YouTube for a free account, or sign in if you are already a member.